Contents

Chapter 1
Using this Supplement
About this guide .................................................................2
Style conventions of this manual ...........................................2

Chapter 2
Defining Your Adobe Premiere Pro Settings
Using Adobe Premiere Pro with Matrox RT.X10 Suite ..............6
A note about running other programs with Adobe Premiere Pro...6
Loading project presets ..........................................................6
Setting up your scratch disks ....................................................7
Defining your General settings ................................................8
  Selecting your NTSC setup level for analog video .................8
  Selecting your codec options for rendering .........................10
  Selecting your DV-1394 settings .........................................11
  Selecting your realtime effect settings ................................13
Defining your Video Rendering and Audio settings ...............15
Performing a Premiere Pro export to disk .........................15
Creating a production in 16:9 format ..................................16

Chapter 3
Setting Up Realtime Effects with Adobe Premiere Pro
How to apply a Matrox video transition in Adobe Premiere Pro ...20
How to apply a Matrox video effect in Adobe Premiere Pro ......20
How to organize your Matrox video effects in custom bins .......21
A note about nested sequences .............................................21
Selecting your speed control method ...................................21
About Adobe Premiere Pro’s fixed effects .............................22
  Applying a Motion effect ..................................................22
  Applying an Alpha Adjust effect ......................................22
What is XtremePreview? .....................................................24
  Adaptive degradation .....................................................24
  Rendering while previewing the Timeline ..........................24
RT.X10 Suite realtime rules ..................................................25
Using this Supplement

This chapter outlines the contents of this manual, and describes the available RT.X documentation.
About this guide

This document supplements information contained in the *Matrox RT.X10 Xtra Installation and User Guide* (May 1, 2003). The *Installation and User Guide* contains important and useful information on installing and using your RT.X system, and should be considered as your primary source of documentation for your RT.X10 Suite.

This *User Guide Supplement* contains updated information about using new features available with Matrox X.tools for use with Adobe Premiere Pro 1.5. The following topics are covered in this supplement:

- **Chapter 2  Defining your Adobe Premiere Pro settings**
  Explains how to define various settings for using your Matrox RT.X with Adobe Premiere Pro, including specifying your project and export settings.

- **Chapter 3  Setting up Realtime Effects with Adobe Premiere Pro**
  Explains how to set up realtime effects using the Matrox realtime plug-in for Adobe Premiere Pro.

- **Chapter 4  Using the WYSIWYG Control Panel**
  Explains how to use the WYSIWYG DirectShow Control Panel to display clips played back using DirectShow programs on your NTSC or PAL video monitor.

Style conventions of this manual

The following style conventions are used in this manual:

- The names of files, directory paths, and manuals appear in *italics*. For example:
  - The data is stored in the *sample.wav* file.
  - The file is located in your C:\Windows\System directory.
  - Please refer to your *Adobe Premiere Pro User Guide*.

- Menus and commands that you need to choose are displayed in the form *Menu > Command*. For example, *File > Save* means click *File* in the menu bar, then click *Save* in the menu that appears.

- The names of keys are displayed in small capital bold letters, such as the *CTRL* key.

- A plus (+) sign is used to indicate combinations of keys and/or mouse operations. For example:
  - *CTRL+C* means to hold down the *CTRL* key while pressing the *C* key.
  - *SHIFT+click* means to hold down the *SHIFT* key while you click an item with the mouse.

Chapter 1, Using this Supplement
Other documentation

In addition to this User Guide Supplement, the following RT.X documents are available.

Quick Start Guide
Your RT.X10 Suite Quick Start Guide gives you a brief introduction to your new Matrox RT.X10 Suite, and shows you how to quickly set up some realtime Matrox RT.X effects in a new Adobe Premiere Pro project.

Installation and User Guide
Your Matrox RT.X10 Xtra Installation and User Guide contains important information on installing your Matrox hardware and software, as well as details on the use of the various Matrox applications and plug-ins. Updated information for using your RT.X10 Suite is provided in this User Guide Supplement.

Release Notes
Any important last-minute information and operational limitations are included in printed Release Notes.

Note  To make sure that you have the latest available software (updates and Service Packs) for your Matrox RT.X system, check the Support section of our web site at www.matrox.com/video/support.

Electronic documents
The following electronic documents are also available:

• HTML-based online Help installed on your hard drive.

  Note  To properly view online Help, you must have Microsoft Internet Explorer 4.0 or later (5.0 or later is recommended).

• A PDF version of this manual and other Matrox RT.X documentation is available from the RT.X Support section of our web site at www.matrox.com/video/support.
Your notes
Defining Your Adobe Premiere Pro Settings

This chapter explains how to define various settings for using your Matrox RT.X with Adobe Premiere Pro. This includes specifying your project and export settings.
Using Adobe Premiere Pro with Matrox RT.X10 Suite

All Adobe Premiere procedures and dialog boxes in your Matrox RT.X10 Xtra Installation and User Guide (May 1, 2003) are for Adobe Premiere 6.5. Many operations in Adobe Premiere Pro are similar to those described in your documentation, but there are a few changes you need to be aware of. The following sections provide important information about using RT.X10 Suite with Adobe Premiere Pro.

For more information about using Adobe Premiere Pro, see your Adobe Premiere Pro User Guide.

A note about running other programs with Adobe Premiere Pro

For the best performance, don’t run any other programs at the same time as Adobe Premiere Pro. Screen savers and programs that use a large amount of system memory, such as most paint and compositing applications, can cause problems if you run them at the same time as Adobe Premiere Pro.

Loading project presets

The Matrox realtime plug-in for Adobe Premiere Pro includes project presets that you can load to immediately apply appropriate RT.X settings.

To load a Matrox RT.X project preset:

2. From the Matrox DV folder, select the preset that matches the type of project you want to create. For example, if you want to capture clips to DV/DVcam format and work in a standard 4:3 editing environment, choose Matrox DV and DVCAM Standard.
3. Under Location, specify where you want to save the project on your A/V drive.
4. Under Name, specify a name for your project.
5. Click OK to apply the settings.

Note Your video source is not automatically selected for you when you choose a project preset. You'll need to specify your required General settings as explained in “Defining your General settings” on page 7, and your required Capture settings as explained in your Matrox RT.X10 Xtra Installation and User Guide.

Chapter 2, Defining Your Adobe Premiere Pro Settings
Setting up your scratch disks

When specifying the location of your scratch disks in Adobe Premiere Pro, make sure you follow the recommendations in your Adobe Premiere Pro User Guide. For example, store your video and audio files on an A/V drive used exclusively for that purpose.

To specify your scratch disks:
1. Choose Edit > Preferences > Scratch Disks.
2. Under Scratch Disks, select an appropriate A/V drive letter for each scratch disk type.
3. Click OK to save your preferences.

Remarks
- If you switch your video standard, you’ll have to set up your scratch disks again.
- To set up DV-1394 device control, choose Edit > Preferences > Device Control.

Defining your General settings

The Matrox Advanced Settings dialog box has several pages that you can use to specify various settings for editing in Adobe Premiere Pro on Matrox RT.X.

Note Any settings or options that are not applicable to Matrox RT.X10 Suite will be unavailable.

When you select an RT.X project preset, such as Matrox DV and DVCAM Standard, your project’s Editing Mode is automatically set to Matrox RT.X, and the aspect ratio for editing is set accordingly (4:3 for the standard TV screen format, or 16:9 for the widescreen format).

To specify your General settings on Matrox RT.X:
1. Choose Project > Project Settings > General and click the Playback Settings button. By default, the General tab is displayed.
2. Under Analog Setup (NTSC), select the setup level you want for your NTSC analog video. For example, select 0 IRE (DV-compliant) when using...
DV-1394 devices that follow the Japanese NTSC standard. For details, see “Selecting your NTSC setup level for analog video” on page 8.

3 Under Error Reporting, select Report dropped frames if you want to be warned each time frames are dropped when you play back video from the Timeline. Otherwise, clear this option.

Remarks
– Once playback of the Timeline has stopped, a red bar will appear over segments of the Timeline that have dropped frames (even if you don’t select Report dropped frames). To perform a Matrox export to DV tape, you must first render the segments identified by the red bar. If you close your project before rendering, the red bar won’t re-appear when you re-open the project.
– If the Display Mode setting for the Program view of the Monitor window is anything other than Composite Video (for example, you’re displaying Premiere Pro’s vectorscope to analyze your video), you will not receive any dropped frames warnings, even if you’ve selected Report dropped frames. Therefore, when you’ve finished analyzing your video, you should set the Display Mode of the Monitor window back to Composite Video.

4 Under Scrubbing Options, select which field (Field 1 or Field 2) you want to display when scrubbing the Timeline. When you scrub the Timeline, or pause or stop playback on the Timeline, only one field is displayed (except when using the render-play or render-scrub feature as explained in “Rendering while previewing the Timeline” on page 24). If you see a “glitch” in your project when you play it back from the Timeline, but notice that when you scrub on the Timeline to find the glitch, you can’t find it, you may need to switch the field you’re scrubbing over. You can then return to the Timeline and find the problem.

5 Click OK to save your settings and return to the Project Settings dialog box. You can specify additional General settings as explained in your Adobe Premiere Pro User Guide.

Selecting your NTSC setup level for analog video
Most commercial DV cameras that have a 1394 interface follow the Japanese specification for analog NTSC video, where the black level (setup) is 0 IRE. The standard setup level for analog NTSC video in North America, however, is 7.5 IRE.

The black level used for the digital bit stream is the same for both Japanese and North American video equipment. This means that when you capture DV video over the 1394 interface on Matrox RT.X, the video is captured at the correct black level. When you play back the captured clips on your NTSC monitor, however,
you may find that the video appears too bright or colors appear to be washed out. This is because the default setup level for the analog output of Matrox RT.X is 7.5 IRE, whereas your DV camera’s analog output uses the Japanese setup level of 0 IRE.

To change the setup level of your analog NTSC video on Matrox RT.X:

1. Choose Project > Project Settings > General.
2. Click the Playback Settings button.

3. Under Analog Setup (NTSC) on the General page, select one of the following setup levels. This affects both the analog video input and output.
   - **0 IRE (DV-compliant)** Applies a setup level of 0 IRE. You should select this option only when working with a commercial DV-1394 device that uses the Japanese analog NTSC setup of 0 IRE. For example, if the video appears too bright when you play back DV clips on your NTSC monitor, you can change the setup to 0 IRE to output your DV clips at the correct brightness.
   - **7.5 IRE** Applies the standard NTSC setup level of 7.5 IRE.

**Note** If your DV-1394 device has a different NTSC setup level for input and output, you can switch the setup level as needed before capturing clips or exporting to tape. If you’re not sure which setup level your DV-1394 device uses for input and output, check with your device’s manufacturer.

4. Click OK to return to the Project Settings dialog box. Your new setup level will take effect only after you restart your computer.
Selecting your codec options for rendering

On the Codec (Rendering) page of the Matrox Advanced Settings dialog box, you can choose whether or not you want Matrox RT.X to show your render results in Premiere Pro’s Monitor window, as well as select your color space conversion options.

When you render material in your Adobe Premiere Pro project on Matrox RT.X, such as preview files for non-realtime effects, you can determine how you want the chroma information to be processed during the color space conversion that’s performed during the render.

Note The default settings for color space conversion provide good results for most applications. We recommend that you change these settings only when needed for special purposes.

To select your codec options for rendering:
1. Choose Project > Project Settings > General.
2. Click the Playback Settings button, then click the Codec (Rendering) tab.
3. Under Monitor Window, select Show render results on computer monitor if you want to view your render results in Premiere Pro’s Monitor window. You can clear this option to improve the speed of rendering.
4. Under Color Space Conversion, select the options you want:
   – Chroma filtering and Chroma interpolation Select these options to adjust the chroma bandwidth of RGB graphics. This improves images that have abrupt changes between different colors, such as a blue box on a black or white background. You should select these options for most animation and compositing work (computer-generated material). For most video material, however, it’s best that you not select these options. If you find that your rendered images appear to be blurred, try clearing one or both of these options.

Chapter 2, Defining Your Adobe Premiere Pro Settings
Chroma sampling for fast-motion video

Select this option to help eliminate artifacts such as jagged edges and unwanted lines at the edges of fast-motion video (for PAL video only).

Important When rendering graphics and titles, make sure that Chroma sampling for fast-motion video is not selected, as this option can cause jagged edges to appear in your rendered images.

5 Click OK to return to the Project Settings dialog box.

Selecting your DV-1394 settings

On Matrox RT.X, you can define various settings for working with DV-1394 devices, such as which DV stereo streams you’d like to capture, and the NTSC time code format of your DV tapes.

To select your DV-1394 settings:

1 Choose Project > Project Settings > General.
2 Click the Playback Settings button, then click the DV-1394 tab.
3 Under 1394 Audio Capture, select which DV stereo audio streams you want to capture. If you capture only one DV stereo stream, the audio stream of your stereo clip will be embedded in your .avi file, creating a single interleaved audio and video file. If you choose to capture both DV stereo streams, the second audio stream will be saved to a separate audio file named clipID_2ndStream.wav.

Remarks

– Some DV-1394 devices let you capture only one stereo audio stream. For more information, consult the documentation that came with your DV-1394 device.

Defining your General settings
When capturing audio over the 1394 interface with certain DV devices (such as Sony or Canon), the left and right channels may be inverted in the resulting file. If this happens, you can select **Invert left and right channels** to correct this problem.

4 If you have an NTSC system, under **Tape Time Code Format**, select the format that matches the format on your DV tapes.

5 Click **OK** to return to the **Project Settings** dialog box.
Selecting your realtime effect settings

You can specify default cropping settings for your realtime Matrox effects, select which Premiere Pro effects you’d like to play back in real time, and determine how you’d like to preview your effects on the Timeline.

To select your realtime effect settings:
1. Choose Project > Project Settings > General.
2. Click the Playback Settings button, then click the Realtime Effects tab.

3. Under Realtime Premiere Pro Effects, you can select the transitions you want to play back in real time, and enable realtime playback of Premiere Pro’s Motion effect and Frame Hold effect:

   - **Select Transitions** Click this button to select the transitions you want to play back in real time. Matrox provides realtime playback by emulating Premiere Pro’s non-realtime version of these transitions. If you don’t like a realtime transition, you can clear (deselect) it to revert to Premiere Pro’s version that requires rendering.

   - **Enable realtime Motion effects** By default, this option is selected. Matrox provides realtime playback of the Motion effect by emulating Premiere Pro’s non-realtime version of the effect. If you don’t like the realtime version of the Motion effect, you can clear this option to revert to Premiere Pro’s version that requires rendering. For more information about the Motion effect, see “Applying a Motion effect” on page 22.

Defining your General settings
– **Enable Frame Hold**  By default, this option is selected. Matrox provides realtime support of Premiere Pro’s Frame Hold to allow you to freeze on a clip’s **In Point**, **Out Point**, or at **Marker 0**. If you encounter repeated frames when playing back a Timeline containing nested sequences or clips with negative speed changes, you can clear this option. If you clear this option, however, all realtime Frame Hold effects applied to clips on the Timeline will be ignored.

**Note**  If you select **Deinterlace** in Premiere Pro’s **Frame Hold** dialog box, your clips will require rendering. The **Hold Filters** option is not supported on Matrox RT.X.

4 **Under XtremePreview Mode**, you can choose the method you want to use to preview (play or scrub) your effects on the Premiere Pro Timeline:

– **Preview all effects**  Lets you preview all video and graphics layers with multiple effects applied, without having to render. If you experience small video and audio glitches when playing certain segments, you may prefer to preview realtime effects only (see below).

– **Preview realtime effects only**  Lets you preview all realtime Matrox effects and realtime Premiere Pro effects (such as realtime transitions and fixed effects). You can also choose to **Ignore unsupported effects**, which lets you ignore Premiere Pro’s non-realtime video effects and transitions, as well as unsupported clip settings, such as field processing options applied to a clip. If you don’t ignore these unsupported effects and settings, these segments will appear as a “not yet rendered” (X) graphic when played back from the Timeline. To see your segment with all effects applied, you can use XtremePreview’s render-play feature (**ALT+SPACEBAR**), or render-scrub feature (**ALT+scrub**).

For more information about the XtremePreview modes, see “What is XtremePreview?” on page 24.

5 **Under Default Cropping for Matrox Effects**, select **Enable cropping** and specify in pixels the default cropping values that you want to be applied each time you create an effect using the Matrox realtime plug-in. For example, if garbage video or black lines appear at the left and right edges of your video, you’ll want to crop these edges so that they’re not visible in your effects. Be aware that your new crop settings will be applied only to subsequent clips you add to the Timeline (that is, clips already on the Timeline won’t be affected).

**Note**  Unless you need cropping to be applied to your clips, make sure that **Enable cropping** is **not** selected. This improves system performance.

6 Click **OK** to return to the **Project Settings** dialog box.
Defining your Video Rendering and Audio settings

When you select an RT.X project preset, your Video Rendering and Audio settings for editing on Matrox RT.X are automatically set for you.

You can specify additional Video Rendering and Audio settings as explained in your Adobe Premiere Pro User Guide.

Important For the best performance, use only 48 kHz, 16-bits/sample (stereo) audio in Adobe Premiere Pro.

Performing a Premiere Pro export to disk

You can export video from the Timeline to a single DV/DVCAM .avi file for purposes such as distribution on CD-ROM and publishing on the web. Several software codecs are included with Adobe Premiere Pro so that you can export your video to different formats. Your Matrox RT.X system adds the Matrox DV/DVCAM codec to the ones included with Premiere Pro. Because the Matrox codec uses your RT.X hardware to accelerate rendering, it can export video much faster than when you use a software codec.

Note The Matrox MediaExport plug-in for Adobe Premiere Pro lets you export your project to various web-optimized and MPEG formats (see Chapter 9, “Using Matrox MediaExport” in your Matrox RT.X10 Xtra Installation and User Guide).

To export your Timeline to a Matrox DV/DVCAM .avi file:

1 Depending on whether you want to export your Timeline or only the current frame from your Timeline, do one of the following:
   - To export all or part of your Timeline, choose File > Export > Movie. Click the Settings button, and from the File Type list, select Matrox RT.X.
   - To export only the current frame from your Timeline, choose File > Export > Frame. Click the Settings button, and from the File Type list, select Matrox RT.X Single-frame AVI.

2 From the Range list, choose an export range, then select additional export options.

3 From the menu on the left side of the dialog box, choose Video.

4 From the Pixel Aspect Ratio list, select the setting that matches the aspect ratio of the material you’re editing:
   - D1/DV NTSC (0.9) For NTSC material that uses the standard TV screen format.
   - D1/DV Widescreen 16:9 (1.2) For NTSC material that uses the widescreen 16:9 format.
-- D1/DV PAL (1.067)  For PAL material that uses the standard TV screen format.
-- D1/DV PAL Widescreen 16:9 (1.422)  For PAL material that uses the widescreen 16:9 format.

5 If you’re exporting all or part of your Timeline, it’s recommended that you do not select Recompress. This retains the quality of your video. It also optimizes the speed of the export because realtime video segments that have no effects will be copied directly to disk without recompression.

6 Choose OK to save your export settings.

Creating a production in 16:9 format

When editing on Matrox RT.X, you can choose to work with source video that’s been recorded in either the 4:3 standard TV screen format, or the widescreen 16:9 format.

To create a production in 16:9 format on Matrox RT.X, do the following:

1 Record your video onto tape with your camera set to the widescreen 16:9 format. The video will be recorded as horizontally compressed 4:3 video.

2 Start Adobe Premiere Pro and select the appropriate Matrox RT.X widescreen preset (such as Matrox DV/DVCam Widescreen). This ensures that the effects you create on Matrox RT.X will be displayed with the correct proportions when viewed in 16:9 format.

Note  When editing in 16:9 format, certain pre-created Matrox organic wipes may appear distorted. For example, circular wipes will appear elongated.

3 Capture your video clips as you normally would. Select the 16:9 display option on your NTSC or PAL video monitor to “unsquish” the video and play it back in widescreen format without distortion.

4 If you create animations, titles, or graphics (including organic wipe patterns) for your production using a program that lets you set the pixel aspect ratio, use the appropriate setting for 16:9 display:
-- On an NTSC system, set the pixel aspect ratio to 1.185.
-- On a PAL system, set the pixel aspect ratio to 1.422.

If you can’t set the pixel aspect ratio, create your image at 853×480 (NTSC) or 1024×576 (PAL). After you’ve created your image, resize only its width to 720. When you resize the image, your text or graphic will appear elongated on your computer screen.

5 Edit your production as you would a standard 4:3 production.
Note  Be aware that if your video monitor is displaying in 4:3 format, certain effects may appear elongated because of the horizontal scaling. Setting your monitor to 16:9 will display the effects with the correct proportions.

6 Record your finished production onto tape. Remember that you’ll need a monitor capable of displaying material in 16:9 format to properly view your master tape.
Your notes
3

Setting Up Realtime Effects with Adobe Premiere Pro

This chapter explains how to set up realtime effects using the Matrox realtime plug-in for Adobe Premiere Pro.
How to apply a Matrox video transition in Adobe Premiere Pro

In Adobe Premiere Pro, all of the video transitions can be found in the Video Transitions bin. By default, the Matrox transitions are found in the Matrox folder.

An easy way to create a Matrox transition is to drag the current-time indicator to the point where two clips meet, then drag the desired effect from the Video Transitions bin in the Effects window to the edit point between the two clips. To set up your Matrox transition, click the transition’s icon on the Timeline, then click the Custom button under your transition in the Effect Controls window. This opens the Matrox Effect Setup dialog box.

Note Because Premiere Pro allows you to apply a transition on any track of the Timeline, you may not always get the desired result when applying a Matrox transition to a single clip when there is another clip on a track beneath it. The result may be that the segment is not realtime (such as with a Matrox particle transition), or that the transition doesn’t display correctly (such as with a Matrox page curl transition). In these cases, you should apply a Matrox video effect instead of a transition. Make sure that you apply Matrox transitions between clips on the same track.

How to apply a Matrox video effect in Adobe Premiere Pro

The Matrox realtime plug-in for Adobe Premiere Pro allows you to apply many realtime video effects to your clips. To apply a Matrox video effect to a clip, drag the desired effect from the Video Effects bin in the Effects window onto the clip on the Timeline. By default, the Matrox video effects are found in the Matrox folder.

To set up your Matrox video effect, click the Setup button ( ) beside your effect in the Effect Controls window. This opens the Matrox Effect Setup dialog box.

Tip If you can’t see the Effects window, choose Window > Effects. If you can’t see the Effect Controls window, choose Window > Effect Controls.
How to organize your Matrox video effects in custom bins

To organize your Matrox video effects and transitions, you can create custom bins in the Effects window. For example, you can create a bin called Shape Effects to hold the Matrox cube, particle, and sphere effects.

To create a new custom bin for your effects:
1. Click the New Custom Bin icon ( ).
2. Locate the new bin by scrolling down to the bottom of the Effects window, then double-click the name of the custom bin and type in a new name.
3. Drag and drop your favorite video effects into their new bin.

Note Dragging and dropping effects into new custom bins only creates a shortcut to the effect. Your Matrox realtime video effects will still remain in their default location (that is, in the Matrox folder located in the Video Effects bin).

A note about nested sequences

To avoid frequent updates to the Premiere Pro Timeline, finish editing your sequences before nesting them inside another sequence. This is because when you make changes to a nested sequence, the master sequence in which you’ve nested this sequence must also be updated.

Selecting your speed control method

You can choose the type of speed control that’s best suited for individual clips in your Premiere Pro projects. By default, the speed control method of each clip on the Timeline is set to Frame Blend Speed Changes, which interpolates between the video fields, and typically works well on standard or slow-paced video and camera pans. If your project contains a series of fast-action clips, however, you may want to change the speed control of these clips to mimic the classic “bob and weave” algorithm found on Betacam machines.

To change the speed control method for a clip on the Timeline:
1. Right-click the clip on the Timeline, and choose Field Options.
2. Select Frame Blend Speed Changes to use the speed control method that’s recommended for standard or slow-paced video and camera pans. For fast-action video, you may get better results by clearing this option.

Remarks
• If you’ve increased a clip’s speed to a value from 101% to 199%, you may experience dropped frames when playing back the clip with Frame Blend Speed Changes selected. This is because of the high demand placed on your system’s CPU. If this happens, clear Frame Blend Speed Changes to...
allow your RT.X10 Suite to analyze these segments and drop frames systematically to smooth out your fast-motion effect.

- The Frame Blend Speed Changes option is not supported for speed changes over 200%.

### About Adobe Premiere Pro’s fixed effects

In Adobe Premiere Pro, every clip on the Timeline has pre-applied fixed effects. When you select the clip on the Timeline, your fixed effects appear in the Effect Controls window. All fixed effects can be adjusted in the Effect Controls window, as well as the Monitor, Timeline, and Audio Mixer windows. Adobe Premiere Pro’s fixed effects include the Motion, Opacity, and Volume effects. Matrox X.tools provides realtime support for all of Premiere Pro’s fixed effects.

### Applying a Motion effect

The Motion effect lets you position, rotate, and scale your clips directly in the Program view of the Monitor window by creating keyframes that contain one or more effect settings for a particular clip. When you select the Motion effect in the Effect Controls window, square handles appear on the clip in the Program view that allow you to adjust the clip’s properties.

The Premiere Pro Motion effect will remain realtime unless you do any of the following:

- Clear the Enable realtime Motion effects option in the Matrox Advanced Settings dialog box. For more information, see “Selecting your realtime effect settings” on page 13.
- Adjust the rotation of a clip with an anchor point applied to it.
- Apply more than one Motion effect in any given segment on the Timeline.

For more information about the Motion effect, see your Adobe Premiere Pro User Guide.

### Applying an Alpha Adjust effect

In Adobe Premiere Pro, graphics clips that have an alpha-key channel on any track on the Timeline are automatically alpha-keyed in real time, so you no longer have to apply an Alpha Channel Key to set up a realtime graphics overlay as explained in your Matrox RTX10 Xtra Installation and User Guide. Matrox X.tools provides limited realtime support of Premiere Pro’s Alpha Adjust effect to let you ignore the alpha-key channel of a clip on the Timeline to turn off an alpha-key effect.

To apply an Alpha Adjust video effect to a clip, drag the desired effect from the Video Effects bin in the Effects window onto the clip on the Timeline. The Alpha Adjust effect is located in the Keying folder.
To set up your effect, click the small triangle to the left of your effect in the **Effect Controls** window. To ignore the alpha-key channel of a clip, select **Ignore Alpha**.

**Note** The Opacity, Invert Alpha, and Mask Only options are **not** supported in real time.

For more information about the Alpha Adjust effect, see your *Adobe Premiere Pro User Guide*. 

About Adobe Premiere Pro’s fixed effects
What is XtremePreview?

XtremePreview lets you edit and preview numerous video and graphics layers without having to render. You can preview all sources (including multiple Matrox effects in any order) for the segment you are editing, even if the segment requires rendering (that is, there is a red bar above the time ruler on the Premiere Pro Timeline). In addition, with XtremePreview, many combinations of Matrox effects remain realtime.

Adaptive degradation

Certain complex effects or combinations of effects can cause dropped frames when previewing. In these cases, XtremePreview performs an adaptive degradation of the video playback by analyzing the segments and dropping frames systematically. With each subsequent playback, that is, every time you replay the clips during the same work session, the segment progressively becomes smoother.

Note

Once playback of the Timeline has stopped, a red bar will appear over the segments that have dropped frames to indicate that these segments will require rendering to perform a Matrox export to DV tape. If you close your project before rendering, the red bar won’t re-appear until you play your project again.

Rendering while previewing the Timeline

Depending on which XtremePreview mode you chose in the Matrox Advanced Settings dialog box (see page 14), you can use different methods to preview effects on your Timeline. If you are using the Preview all effects mode, when you play or scrub the Timeline, XtremePreview performs an on-the-fly render whenever a non-realtime segment is encountered (that is, an automatic render-play or render-scrub is performed).

When using the Preview realtime effects only mode, segments that include non-realtime effects appear as a “not yet rendered” (X) graphic when played back from the Timeline. In these cases, you can choose to Ignore unsupported effects, which lets you ignore Premiere Pro’s non-realtime video effects and transitions, as well as unsupported clip settings, such as field processing options applied to a clip. To see your segment with all effects applied, you can render-play (ALT+SPACEBAR), or render-scrub (ALT+scrib) the Timeline.

The render-play feature is system dependent (that is, the video quality and frame rate degrade during complex segments). It should, however, provide a good indication of how a segment will look with all effects applied.

Remarks

• Adjustments to Premiere Pro’s Program view Quality settings affect segments on which you are using the render-play feature.
You may notice a small video and audio glitch when your Timeline starts or completes playing certain segments when using the render-play feature.

The render-play feature does not support shuttling or reverse playback of clips.

Previewing a clip in the Matrox Effect Setup dialog box always uses the Preview all effects XtremePreview mode. You can, however, manually preview only the current source for the effect you are editing by clicking the Solo Mode button. When using solo mode, you can $\text{ALT}+$drag the Positioner to see the segment with all applied effects.

RT.X10 Suite realtime rules

In your Adobe Premiere Pro projects, you can use various combinations of realtime Matrox RT.X CPU-based effects, hardware-accelerated effects, and Adobe Premiere Pro realtime transitions and fixed effects, all with transparency.

![Note](https://via.placeholder.com/15)

Realtime means that you won’t need to render the segment on the Timeline to perform a Matrox export to DV tape (that is, there is no red indicator bar above the segment). You’ll still be able to preview segments that require rendering, as explained in “What is XtremePreview?” on page 24.

The Matrox CPU-based effects are color corrections, and speed changes applied to a clip. The CPU-based effects can be applied only to video clips in real time. The Matrox hardware-accelerated effects are all the other RT.X effects (such as page curls, particles, Premiere Pro realtime transitions, and fades). The hardware-accelerated effects can be applied to video or graphics clips in real time.

![Note](https://via.placeholder.com/15)

This section explains the rules and guidelines you’ll need to follow in order to keep your effects realtime, assuming that you’re using a recommended system, as explained in the Matrox RT.X10 Suite Release Notes.

Supported graphics formats

All full-screen single-frame graphics supported by Adobe Premiere Pro are supported in real time on a Matrox RT.X system. This includes all titling formats that Premiere Pro supports, such as Adobe Title Designer .prtl files. For details on the supported formats, see your Adobe Premiere Pro User Guide.

![Tip](https://via.placeholder.com/15)

With XtremePreview, you can pan or zoom larger than full-screen graphics clips, and preview the results in real time.
General rule
The general rule to follow to avoid the red indicator bar when setting up your realtime effects is that in any given segment, you can use up to two video clips (.avi files), and up to four single-frame graphics clips.

Each clip in the segment can have a fade applied to it. A fade can be any one of the following:

- Opacity changes applied to a clip, such as by adjusting the Opacity handles of a clip.
- An Adobe Premiere Pro Cross Dissolve.
- An alpha-keyed graphics clip.

Combining effects
In any given segment, you can apply the following RT.X effects in real time:

- 2 color correction effects, and
- 2 speed changes, and
- at least 1 Matrox hardware-accelerated effect (such as a page curl or a Premiere Pro realtime transition). You may be able to combine more than 1 Matrox hardware-accelerated effect in your segment in real time, depending on the type and complexity of the effects (excluding Matrox effects based on pattern files).

Note Certain complex Matrox effects, such as particles, may not be realtime when applied to a segment containing multiple graphics clips.

Order of effects
The order in which you apply your RT.X effects is important when you combine effects. When applying multiple RT.X effects to a segment, follow this order:

1. Color correction effect(s).
2. Matrox hardware-accelerated effect.

For example, you can apply a page curl to a color correction and not require rendering. If, however, you apply a color correction to a page curl, the clip will require rendering (unless you change the order of the effects).

Note If this order is not followed, you’ll still be able to preview your segment with XtremePreview.

To change the order of effects applied to a particular clip, you can drag and drop effects in Premiere Pro’s Effect Controls window. In the following example,
Matrox Page Curls appears after Matrox Color Corrections. Therefore, the clip will remain realtime:

Restrictions
If you follow the rules listed above, your effects will remain realtime. You will, however, need to render your effects when you do any of the following:

- Select **Force render** when you set up an effect in the Matrox Effect Setup dialog box.
- Place effects or clips too close on the Timeline, as explained in the section “How to place your effects to avoid rendering” in the “Setting Up Realtime Effects with Adobe Premiere” chapter of your Matrox RT.X10 Xtra Installation and User Guide.
- Use a graphics roll, crawl, animation, or non-full screen graphics clip (only full-screen single-frame graphics are supported in real time).
- Apply a Matrox color correction to a graphics clip.
- Add a non-Matrox effect or transition, such as a non-realtime Adobe Premiere Pro video effect or transition. For details on selecting which Adobe Premiere Pro transitions you want to play back in real time, see “Selecting your realtime effect settings” on page 13.
- Apply any **Field Options** to a clip (other than **Frame Blend Speed Changes**), such as **Always Deinterlace** or **Flicker Removal**.
- Apply a freeze-frame effect to a clip using the **Frame Hold** command with the **Deinterlace** option selected (rendering won’t be required if you clear the **Deinterlace** option).

**Note** Non-realtime segments of the Timeline (that is, areas that require rendering) are identified by a red bar above the time ruler.
Chapter 3, Setting Up Realtime Effects with Adobe Premiere Pro
Using the WYSIWYG DirectShow Control Panel

This chapter explains how to use the WYSIWYG DirectShow Control Panel to display clips played back using DirectShow programs on your NTSC or PAL video monitor.
Overview

The WYSIWYG DirectShow Control Panel lets you display video played back using Windows Media Player, Adobe Encore DVD, and other supported DirectShow applications on your NTSC or PAL video monitor. This gives you a WYSIWYG (What You See Is What You Get) video display for checking how your clips appear on a TV or other interlaced monitor.

The supported file types include: Matrox .avi and .m2v files, as well as Video CD and Super Video CD files (.mpg, .m1v, and .m2v files).

If you’ve connected an S-Video or composite video recorder to your RT.X system, you can record your clips onto tape as they play back on your video monitor.

Remarks

- To disable and re-enable the Matrox WYSIWYG DirectShow output to your video monitor, you must log onto an account on your Windows system that has Administrator privileges. For details, consult the appropriate Microsoft documentation.
- When playing non-interlaced video clips on your video monitor, you may see some flickering in your image that is not present in the image on your computer screen. This is normal.
Configuring the WYSIWYG DirectShow Control Panel

1. To open the WYSIWYG DirectShow Control Panel, click the icon on your Windows taskbar.

   **Note** If you do not see the icon, right-click the taskbar and choose Properties. Clear the Hide inactive icons option, and click OK.

2. By default, the Matrox WYSIWYG DirectShow output to your NTSC or PAL monitor is enabled. Some DirectShow applications, however, may not display the video properly. If this happens, you can disable the display on your video monitor by clicking the Disable button.

   **Note** After choosing Enable or Disable, you’ll need to restart your DirectShow application for the change to take effect.

3. Under Output Size, select the size that you want your video to be displayed on your NTSC or PAL video monitor. For example, select Original to maintain the original size of your clip.
4 By default, the **Play associated audio (.wav) file** option is selected. Some DirectShow programs, such as DVDit! SE, automatically play back associated audio files for video clips. Therefore, if you hear an echo when playing back video on your NTSC or PAL video monitor, you should disable playback of the associated audio file by clearing **Play associated audio (.wav) file**, and restart your DirectShow application for the change to take effect.
## Index

**A**
- Adaptive degradation
  - definition 24
- Adobe Encore DVD
  - displaying project on video monitor 30
- Adobe Premiere Pro
  - Alpha Adjust effect 22
  - applying a Motion effect 22
  - Capture settings 15
  - Export Frame settings 15
  - Export Movie settings 15
  - fixed effects 22
  - General settings 7
  - loading Matrox project presets 6
  - selecting realtime Premiere Pro transitions 13
  - setting up scratch disks 7
  - See also Realtime plug-in for Adobe Premiere Pro
- Alpha Adjust effect
  - applying in Premiere Pro 22
- Aspect ratio
  - See Editing aspect ratio
- AVI files
  - exporting using Adobe Premiere Pro 15

**C**
- Capturing using Adobe Premiere Pro
  - specifying settings for 15
- Chroma filtering and chroma interpolation for rendering in Adobe Premiere Pro 10
- Chroma sampling for fast-motion video for rendering in Adobe Premiere Pro 11
- Color space conversion options for rendering in Adobe Premiere Pro 10
- Cropping
  - default setting for Matrox effects 14
- Custom bins
  - organizing in Premiere Pro 21

**D**
- DirectShow programs
  - displaying clips on video monitor 30
- Documentation
  - about this guide 2
  - other documentation 3
  - style conventions 2
- Dropped frames in realtime effects
  - adaptive degradation with XtremePreview 24
  - reporting 8
- DV-1394 device
  - settings in Adobe Premiere Pro 11

**E**
- Editing aspect ratio
  - creating production in 16:9 format 16
- Error reporting
  - for dropped frames during video playback 8
- Exporting
  - Matrox clips in Adobe Premiere Pro 15

**F**
- Fixed effects
  - applying in Premiere Pro 22
- Frame Hold
  - enabling realtime playback 14

**G**
- Graphics clips
  - supported formats 25
- Graphics overlays
  - setting up in Adobe Premiere Pro with Alpha Adjust 22

**M**
- Motion effect
  - applying in Premiere Pro 22
  - enabling realtime playback 13
Index

N
Nested sequences editing in Premiere Pro 21
NTSC setup level selecting for analog video 7, 8

P
Project presets loading for Matrox RT.X 6

R
Realtime plug-in for Adobe Premiere Pro applying a Matrox transition 20
applying a Matrox video effect 20
default crop settings 14
editing nested sequences 21
organizing custom bins 21
realtime rules 25
selecting realtime Premiere Pro transitions 13
speed control method 21
Rendering using Adobe Premiere Pro selecting color space conversion options when you’ll need to render 27
Render-play feature 24
Render-scrub feature 24
Reporting dropped frames during video playback 8

S
Scratch disks specifying 7
Scrubbing types switching between 8
Setup level selecting for NTSC analog video 7, 8
Speed control method selecting 21

T
Titles setting up in Adobe Premiere Pro with Alpha Adjust 22

supported formats 25
Transitions applying realtime 20
selecting realtime Adobe Premiere Pro 13

V
Video effects applying realtime 20

W
WAV files captured audio in Adobe Premiere Pro 11
Widescreen format editing material on Matrox RT.X 16
Windows Media Player displaying clips on video monitor 30
WYSIWYG DirectShow Control Panel configuring 31
overview 30

X
XtremePreview definition 24
selecting mode 14
Your notes
Your notes